Melodeon.net Forums

Forum and website admin => Support => Topic started by: Steve_freereeder on December 29, 2008, 11:03:15 AM

Title: 'Show unread posts since last visit' option
Post by: Steve_freereeder on December 29, 2008, 11:03:15 AM
Since about mid-December, the 'Show unread posts since last visit' option no longer seems to be working for me. It invariably returns a 'No new posts' result, even though there ARE new posts.

Has something been tweaked to make this option stop working? I hope it can be restored, as it was something that I used a lot. Has anyone else been experiencing difficulties?

Cheers
Steve
Title: Re: 'Show unread posts since last visit' option
Post by: Rees on December 29, 2008, 11:33:46 AM
Yes, I have also lost this most useful facility.
Title: Re: 'Show unread posts since last visit' option
Post by: Waltham on December 29, 2008, 11:39:33 AM
Still works for me.
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on December 29, 2008, 12:41:56 PM
Where do you find this option Steve?  I've not changed it on purpose.   I did have to repair a damaged file a couple of weeks ago, and may have not restored all the relevant settings.
Title: Re: 'Show unread posts since last visit' option
Post by: Brian G on December 29, 2008, 01:31:57 PM
Yes, I also am experiencing this problem.  Although it worked just now and this visit.
Title: Re: 'Show unread posts since last visit' option
Post by: Bill Young on December 29, 2008, 01:33:02 PM
This option has mostly stopped working for me since 2-3 days ago (worked a couple of times, but not this visit). Theo, it's right at the top of the page - the first thing opposite the avatar, below "Hello Joe Soap", and above "Show new replies to your posts".
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on December 29, 2008, 01:39:36 PM
Thanks Bill,  I always have that panel turned off to save screen space.

It appears to be a bug introduced with a recent security update to the forum software. A fix that works for some people is to clear cookies from your browser.
Title: Re: 'Show unread posts since last visit' option
Post by: ganderbox on December 29, 2008, 02:17:33 PM
For the last couple of weeks, the forum home page has failed to recognise me as a member (it says "hello guest"). If I click on any heading or topic in the list, however, then when that page comes up it greets me by my username and offers me the "show unread posts since last visit" option, and works fine from then on. 

Pauline
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on December 29, 2008, 03:38:35 PM
Hi Pauline

That might also be due to something going wrong with cookies.
Title: Re: 'Show unread posts since last visit' option
Post by: Québécois on December 29, 2008, 04:30:06 PM
Most probably a cookie issue, I access the forum from 3 machines and the option seems to work fine on one and not on the two others, since the last few days.
Title: Re: 'Show unread posts since last visit' option
Post by: waltzman on December 29, 2008, 05:34:31 PM
Most probably a cookie issue, I access the forum from 3 machines and the option seems to work fine on one and not on the two others, since the last few days.

The option doesn't work on either one of my two machines.
Title: Re: 'Show unread posts since last visit' option
Post by: Québécois on December 29, 2008, 07:33:35 PM
You can still use the "Click here to try all unread topics" link.
Title: Re: 'Show unread posts since last visit' option
Post by: Steve_freereeder on December 31, 2008, 08:25:23 AM
It appears to be a bug introduced with a recent security update to the forum software. A fix that works for some people is to clear cookies from your browser.
Thanks for the info, Theo.

Have deleted cookies, etc. The problem is still apparent, but intermittently (always the worst kind of fault! :( ). I use a Mac running Safari 3.2 to browse this forum. I wonder if it is a Mac thing.
Title: Re: 'Show unread posts since last visit' option
Post by: Mike Higgins on December 31, 2008, 09:02:51 AM
It appears to be a bug introduced with a recent security update to the forum software. A fix that works for some people is to clear cookies from your browser.
Thanks for the info, Theo.

Have deleted cookies, etc. The problem is still apparent, but intermittently (always the worst kind of fault! :( ). I use a Mac running Safari 3.2 to browse this forum. I wonder if it is a Mac thing.

Its not a Mac thing, I am using winxp and it is an intermittent fault for me too. Happy New Year to everyone.
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on December 31, 2008, 11:18:50 AM
Have deleted cookies, etc. The problem is still apparent, but intermittently (always the worst kind of fault! :( ). I use a Mac running Safari 3.2 to browse this forum. I wonder if it is a Mac thing.

I use a mac, and I've just tried Firefox, Safari, and Camino all worked correctly, but only tried once!
Title: Re: 'Show unread posts since last visit' option
Post by: Steve_freereeder on December 31, 2008, 02:24:41 PM
Have deleted cookies, etc. The problem is still apparent, but intermittently (always the worst kind of fault! :( ). I use a Mac running Safari 3.2 to browse this forum. I wonder if it is a Mac thing.

I use a mac, and I've just tried Firefox, Safari, and Camino all worked correctly, but only tried once!
Thanks, Theo.
Now I find can't stay logged in, even though I've selected the option to always remain logged in! Grr!
Title: Re: 'Show unread posts since last visit' option
Post by: Fidjit on December 31, 2008, 03:15:33 PM
Now why is that when I log in.

Type my e-mail (This comes up after the first letter)

Then I type my password (correctly)

I get this message

< Not Acceptable
An appropriate representation of the requested resource /smf/index.php could not be found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.41 Server at www.melodeon.net Port 80 >

Then, when I go back and again type the password correctly I am accaepted. ???

Chas
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on December 31, 2008, 03:27:41 PM
Now why is that when I log in.

Type my e-mail (This comes up after the first letter)

Then I type my password (correctly)

I get this message

< Not Acceptable
An appropriate representation of the requested resource /smf/index.php could not be found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.41 Server at www.melodeon.net Port 80 >

Then, when I go back and again type the password correctly I am accaepted. ???

Chas


Are you sure you typed your password correctly the first time?  Typos are easy to make - just look at the last line above your name in the quoted text!

Title: Re: 'Show unread posts since last visit' option
Post by: Steve_freereeder on December 31, 2008, 03:29:59 PM
Now why is that when I log in.
Type my e-mail (This comes up after the first letter)
Then I type my password (correctly)
I get this message
< Not Acceptable
An appropriate representation of the requested resource /smf/index.php could not be found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.41 Server at www.melodeon.net Port 80 >
Then, when I go back and again type the password correctly I am accaepted. ???
Chas
Are you sure you typed your password correctly the first time?  Typos are easy to make - just look at the last line above your name in the quoted text!
Chas, Theo,
I have been experiencing exactly the same problem as Chas. It's happened each time I try to log in and it's not because I'm making typos either!
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on December 31, 2008, 03:48:43 PM
The only difference I can see from what I'm doing is that I always log in with my username and password, rather than email address and password.  I wonder if that makes a difference?
Title: Re: 'Show unread posts since last visit' option
Post by: Lester on December 31, 2008, 04:53:24 PM
I'm suffering from a Logon problem, every so often, I get:

Code: [Select]
Not Acceptable
An appropriate representation of the requested resource /smf/index.php could
not be found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an
ErrorDocument to handle the request

Seems best cured by deleting my cookie and logging on but sometimes it just takes a long wait.

This seem to be on the increase?
Title: Re: 'Show unread posts since last visit' option
Post by: Fidjit on December 31, 2008, 05:15:16 PM
No. I note that I type the password correctly each time.

Chas
Title: Re: 'Show unread posts since last visit' option
Post by: Québécois on December 31, 2008, 05:41:45 PM
One option would be to clear the browser's cache, off-line content, delete existing cookies, then log-in again to start fresh.
Title: Re: 'Show unread posts since last visit' option
Post by: Steve_freereeder on December 31, 2008, 05:55:37 PM
One option would be to clear the browser's cache, off-line content, delete existing cookies, then log-in again to start fresh.
Yep - did all that. Several times, in fact. No joy :(
Title: Re: 'Show unread posts since last visit' option
Post by: Steve_freereeder on December 31, 2008, 05:58:28 PM
The only difference I can see from what I'm doing is that I always log in with my username and password, rather than email address and password.  I wonder if that makes a difference?
I always log in with my username and password, and still am having problems. Summat's been tweaked somewhere, I reckon.
Sorry Theo :(

If it's any help, the forum seems to be more stable when I use Firefox rather than Safari.
Title: Re: 'Show unread posts since last visit' option
Post by: Ellie on December 31, 2008, 06:36:39 PM
I've been having that same problem with logging in - the same on about 4 different computers, all of which have my username and password saved correctly  :-\ It generally works second time  ???
Title: Re: 'Show unread posts since last visit' option
Post by: Rees on December 31, 2008, 07:01:25 PM
Same problems here using FireFox on Windows XP.
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on December 31, 2008, 07:18:48 PM
It may be I'll have to re-install the forum software.  I did an upgrade a couple of months ago which failed the first time, bt succeeded the second, something may have been broken in the process.
Title: Re: 'Show unread posts since last visit' option
Post by: Lester on December 31, 2008, 08:52:42 PM
What seems to work for me is to ignore the Logon on the Forum Home Page, open any sub=-page and then go back to the home page and it then says Hello Lester!

Hope this helps
Title: Re: 'Show unread posts since last visit' option
Post by: ganderbox on January 01, 2009, 10:05:10 AM
Lester's solution is the same as mine. I have now bookmarked the forum's general discussion sub-page (which recognises me) so that whenever I want to use the site I can bypass the home-page.

Pauline
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on January 01, 2009, 10:53:33 AM
OK I may have found the cause of this problem and fixed it by changing some server settings.

Would all those having problems with logging in and viewing recent posts please post here if things are still the same, or are better.
Title: Re: 'Show unread posts since last visit' option
Post by: Fidjit on January 01, 2009, 11:44:56 AM
Just logged in and it worked first time this time.

Happy New Year.

Chas
Title: Re: 'Show unread posts since last visit' option
Post by: Ellie on January 01, 2009, 02:17:55 PM
Worked first time for me too :)
Title: Re: 'Show unread posts since last visit' option
Post by: RGF on January 01, 2009, 02:20:11 PM
Nope, sorry........still doesn't work for me!

Bob
Title: Re: 'Show unread posts since last visit' option
Post by: RGF on January 01, 2009, 02:55:28 PM
Hmmm.......this time it did work for me. Didn't log out/in or anything, just went elsewhere for a bit. Returned, clicked the "Show unread posts" button, and up came two. Hopefully it's working for me again.

Bob
Title: Re: 'Show unread posts since last visit' option
Post by: ganderbox on January 01, 2009, 05:34:28 PM
The Forum home-page still thinks I'm a guest. I tried logging in on that page, (which I did successfully) then closed the window, then went back in to see if that had fixed it, but it greeted me as a guest again. I'll just carry on bypassing the home-page.

Pauline

 
Title: Re: 'Show unread posts since last visit' option
Post by: Rees on January 01, 2009, 08:39:32 PM
Still not working, sorry Theo.
Title: Re: 'Show unread posts since last visit' option
Post by: Mike Higgins on January 01, 2009, 09:12:13 PM
Theo, its fixed for me.

Mike
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on January 01, 2009, 09:23:05 PM
Pauline, Rees,

Could you try the following please:
clearing cookies
clear browser cache
quit browser
re-launch browser

and then tell me if anything is different.
Title: Re: 'Show unread posts since last visit' option
Post by: Lester on January 01, 2009, 11:15:40 PM
Is this just a replacement for the torches that haunted us on the old board?   :P
Title: Re: 'Show unread posts since last visit' option
Post by: Steve_freereeder on January 01, 2009, 11:31:23 PM
Pauline, Rees,

Could you try the following please:
clearing cookies
clear browser cache
quit browser
re-launch browser

and then tell me if anything is different.
Theo,
I've tried doing this too. Still no joy. I can't stay logged in and the 'show unread posts since last visit' is not working either.
Sorry. Thanks for trying to help.
Title: Re: 'Show unread posts since last visit' option
Post by: Rees on January 02, 2009, 01:39:09 PM
Pauline, Rees,

Could you try the following please:
clearing cookies
clear browser cache
quit browser
re-launch browser

and then tell me if anything is different.

Well, I did all that and there's no change.
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on January 02, 2009, 02:53:26 PM
bugger ???
Title: Re: 'Show unread posts since last visit' option
Post by: Québécois on January 02, 2009, 03:04:34 PM
Funnily enough, this topic is the only one showing up when using the link!

However, using the "click here to try all unread topics" link works like the "show unread topics" should... like if their functionality had been swapped!

Title: Re: 'Show unread posts since last visit' option
Post by: Stiamh on January 02, 2009, 03:58:11 PM
Unread topics since last visit show up correctly if I leave the site but don't close my browser. If I do close my browser or visit from my other computer, no unread topics show.
Title: Re: 'Show unread posts since last visit' option
Post by: ganderbox on January 02, 2009, 05:30:17 PM
Pauline, Rees,

Could you try the following please:
clearing cookies
clear browser cache
quit browser
re-launch browser

and then tell me if anything is different.

Well, I did all that and there's no change.


I did it too, and likewise no change.

Pauline
Title: Re: 'Show unread posts since last visit' option
Post by: Rees on January 02, 2009, 05:31:33 PM
I've just tried it again and it works fine.
Title: Re: 'Show unread posts since last visit' option
Post by: Stiamh on January 02, 2009, 05:44:50 PM
Have you changed anything Theo? Today it seems the link is programmed to display only ads for Bompezzo Italian-style boxes  ;)
Title: Re: 'Show unread posts since last visit' option
Post by: tjsmithdog5 on January 02, 2009, 08:12:10 PM
My browser is Firefox.  I went to the "show cookies" option, deleted the two cookies put there by melodeon.com, and now the unread posts show up exactly as before. Thanks for the tip.

    --Jeff
Title: Re: 'Show unread posts since last visit' option
Post by: RGF on January 03, 2009, 04:53:50 AM
Our machine is running Windows Vista, Internet Explorer. I've just deleted all my browsing history and all my cookies, and logged back in with my user name, correct password, and "Forever" session length. I am then welcomed by name, but whenever I return thereafter, I'm greeted once again as "guest".

Bob

Title: Re: 'Show unread posts since last visit' option
Post by: Steve_freereeder on January 03, 2009, 08:57:13 AM
Our machine is running Windows Vista, Internet Explorer. I've just deleted all my browsing history and all my cookies, and logged back in with my user name, correct password, and "Forever" session length. I am then welcomed by name, but whenever I return thereafter, I'm greeted once again as "guest".
Yes - that is my experience too. ???
Title: Re: 'Show unread posts since last visit' option
Post by: Rees on January 03, 2009, 11:42:51 AM
That is also happening to me now.
Title: Re: 'Show unread posts since last visit' option
Post by: an bosca ceoil on January 03, 2009, 02:32:44 PM
I first experienced problems when, after always being permanantly logged in, I suddenly became logged out for no apparent reason.
 I managed to log back in, not without some *difficulty, but could not get the "permanant" log in function accepted.
( *I suspect that this difficulty arose from the fact that, inspired by G. G., I adopted my current I.D. which was getting confused with the original one)
 Consequently each time I visit the forum page I am greeted as Guest and invited to log in.
I have however discovered that by just clicking the "log in" link above the detail boxes, without completing them, it takes me to the log in page, greeting me and displaying the link to latest unread posts.
Just clicking this link usually works, again without filling in any details.
Title: Re: 'Show unread posts since last visit' option
Post by: RGF on January 03, 2009, 09:00:58 PM
Hmmmm.....Not the same for me. When I try clicking on the "Log In" link above the detail boxes, it still asks me for detailed login information, which it then does not remember on subsequent visits.

Sorry I'm just not computer savvy enough to be able to make any helpful suggestions, but just hoping that some remark made here or there along the way might help contribute to that "Ah-HA!" moment. Thanks to all the more knowledgeable folks who are helping to sort this all out, especially Theo.

Bob
Title: Re: 'Show unread posts since last visit' option
Post by: risto on January 03, 2009, 09:10:46 PM
Could this be a Simple Machines version 1.1.7 programming issue? Viljo started the Finnish Free reed site with Simple Machines and all sorts of problems occuring there (like unable to include file attachment etc.) when using IE7 but works fine with Firefox...
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on January 03, 2009, 11:54:52 PM
I think you may be right Risto in that the problems only came to light after I upgraded to SMF1.1.7,  but there was also a problem with the server which meant I had to reinstall some files, so there is more than one possibility.
Title: Re: 'Show unread posts since last visit' option
Post by: petefoth on January 04, 2009, 10:16:20 AM
I was having a similar problem - instead of taking me to the 'Show unread posts since last visit' option, my bookmark was going to the login screen, and not remembering that I was already logged in.
I fixed it by updating my bookmark which now points to http://www.melodeon.net/smf/index.php?action=unread. I can't remember what the value was before, but I'm pretty sure it didn't have 'smf' in it.
Hope this helps.
Pete
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on January 04, 2009, 10:57:09 AM
I've changed one more server setting related to cookies which may help the problem of login not persisting.

Any change?
Title: Re: 'Show unread posts since last visit' option
Post by: an bosca ceoil on January 04, 2009, 11:31:01 AM
Think you may have cracked it!
Can now achieve "permanant" log in and things seem to be as they were.
Also, it is now highlighting Yesterday posts - previously it only did Today ones.
Title: Re: 'Show unread posts since last visit' option
Post by: Rees on January 04, 2009, 01:18:12 PM
I do believe it's behaving itself now.

I'll keep you posted.
Title: Re: 'Show unread posts since last visit' option
Post by: Lester on January 04, 2009, 01:53:03 PM
Works OK for me on my desktop, laptop and iPod.

Many thanks
Title: Re: 'Show unread posts since last visit' option
Post by: risto on January 04, 2009, 02:37:15 PM
Works fine now.
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on January 04, 2009, 02:49:31 PM
Steve how is it for you?
Title: Re: 'Show unread posts since last visit' option
Post by: RGF on January 04, 2009, 06:18:35 PM
Everything here seems to be working just as it should. THANKS!

Bob
Title: Re: 'Show unread posts since last visit' option
Post by: Steve_freereeder on January 04, 2009, 06:25:39 PM
Steve how is it for you?
<whispers cautiously>
The permanent login now seems OK. Not sure about the 'Show unread posts since last visit' yet, but I think it might be OK too!
</whispers cautiously>
Many thanks Theo! I'll keep track of things and let you know how it goes.
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on January 04, 2009, 06:32:55 PM
Phew ;)
Title: Re: 'Show unread posts since last visit' option
Post by: ganderbox on January 04, 2009, 10:26:28 PM
I couldn't get in at all just now without logging in, but having done so everything seems to be working as it was originally. Looks like it could be fixed!

Pauline
Title: Re: 'Show unread posts since last visit' option
Post by: Steve_freereeder on January 05, 2009, 01:10:10 AM
Steve how is it for you?
<whispers cautiously>
The permanent login now seems OK. Not sure about the 'Show unread posts since last visit' yet, but I think it might be OK too!
</whispers cautiously>
Many thanks Theo! I'll keep track of things and let you know how it goes.
Yes - a few hours later, having reopened my browser and clicked on the site bookmark - it all seems to be working OK now.
Theo, I think you really have cracked it now! Many thanks and well done!
Title: Re: 'Show unread posts since last visit' option
Post by: Rees on January 05, 2009, 04:55:18 PM
No problems at all here now. Well done old bean.
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on January 15, 2009, 10:57:23 AM
Thanks everyone for your patience.  This one seems to be sorted now - or so I thought. I had a problem recently, the forum would not let me log out! Clearing cookies solved it.
Title: Re: 'Show unread posts since last visit' option
Post by: Bill Young on April 22, 2009, 01:28:00 PM
Having problems again with this, over last couple of days. Just now it came up "No unread posts since last visit", but in fact there were 12+ this morning that I hadn't read. Tried logging out and in again -still doesn't work.
Title: Re: 'Show unread posts since last visit' option
Post by: Owen Woods on April 22, 2009, 02:09:38 PM
Yeah, it doesn't work for me from time to time. "show new replies to your posts" sill does though.
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on April 22, 2009, 03:27:28 PM
Try clearing your browsers cookies, and cache.
Title: Re: 'Show unread posts since last visit' option
Post by: Mike Higgins on May 16, 2009, 11:42:37 AM
Is there a problem with the "unread posts" facility? I am using firefox with win 2000 and there are heaps of things I haven't read but I get a blank when selecting "unread posts since last visit". its not a big deal as I just go to the forum home page and browse about.

Regards

Mike
Title: Re: 'Show unread posts since last visit' option
Post by: Theo on May 16, 2009, 06:40:10 PM
For me it works correctly for Camino, but not with Firefox 3.0.10 on OSX
Title: Re: 'Show unread posts since last visit' option
Post by: old geezer on May 17, 2009, 08:14:33 AM
 OK with mine
firefox 3.0.10 on xp
Title: Re: 'Show unread posts since last visit' option
Post by: Steve_freereeder on May 17, 2009, 11:26:42 AM
 'Show unread posts since last visit' option currently OK for me with Safari 3.2.1 on Mac OSX; used to be OK with older versions of Firefox, but now doesn't seem to work on Firefox 3.0.10 on Mac OSX.
Title: Re: 'Show unread posts since last visit' option
Post by: Mike Higgins on May 17, 2009, 12:30:04 PM
From the posts above it looks like the problem is with Firefox 3.0.10, which is my current version. I'll try another browser and see what happens. Thanks for the replies.